bsc testnet rpc service down

Incident Report for BlockPI

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 07:17 UTC

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 17:24 UTC

Investigating

Due to corrupted BSC testnet data, our BSC testnet node RPC service is currently offline. We are in the process of repairing it. Please be patient, and we sincerely apologize for the inconvenience caused.
Posted Nov 20, 2025 - 02:28 UTC
This incident affected: BSC (BSC Testnet Full - HTTPS API, BSC Testnet Full - WSS API, BSC Testnet Archive - HTTPS API, BSC Testnet Archive - WSS API).