The Polygon mainnet rpc service is down due to Erigon client issue

Incident Report for BlockPI

Resolved

This incident has been resolved.
Posted Jul 19, 2025 - 04:09 UTC

Investigating

The Polygon mainnet is currently unavailable due to Erigon client issues that have caused the chaindata to become corrupted. We are working to restore the data and the RPC service as soon as possible.
Posted Jul 18, 2025 - 20:38 UTC
This incident affected: Polygon (Polygon Mainnet Archive HTTPS API, Polygon Mainnet Archive WSS API).