The Polygon mainnet service is down due to Erigon client issue

Incident Report for BlockPI

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 01:42 UTC

Update

The Polygon mainnet is currently unavailable due to Erigon client issues that have caused the chaindata to become corrupted. We are working to restore the data and the RPC service as soon as possible.
Posted Jul 01, 2025 - 09:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 01, 2025 - 09:14 UTC

Identified

The Polygon mainnet is currently unavailable due to client issues that have caused the chaindata to become corrupted. We are working to restore the data and the RPC service as soon as possible.
Posted Jul 01, 2025 - 09:12 UTC
This incident affected: Polygon (Polygon Mainnet Full - HTTPS API, Polygon Mainnet Full - WSS API, Polygon Mainnet Archive HTTPS API, Polygon Mainnet Archive WSS API).