Polygon archive RPC service is facing some problems.

Incident Report for BlockPI

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 03:48 UTC

Investigating

We are currently investigating this issue.
Posted Jan 13, 2026 - 03:24 UTC
This incident affected: Polygon (Polygon Mainnet Archive HTTPS API, Polygon Mainnet Archive WSS API).